Tag Archives: Windows-8.1

Troubleshooting on very large Windows.edb file on Windows 8.1

Challenges

This machine is a Apple MacBook running bootcamp for Windows 8.1 and it’s been running for almost 1+ year and now we are facing the increasing Windows.edb file (50GB+) and we have to do temporarily solution by deleting this file and redo the indexing again. Eventually it came up again after month or so.

Solution

At this stage, there is no real solution yet from Microsoft. The following steps are temporarily solution:

a. Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.
b. Tap or click Settings.
c. In the search box, type indexing options.
d. Tap or click Indexing Options.
e. Tap or click Advanced.
f. Tap or click Rebuild on the Indexing Settings tab.
g. Tap or click OK to confirm.

Alternatively, for temporarily solution:

a. Search for “Indexing Options” (under “Settings”). Open it.
b. Search “services” (or run “services.msc”) and find “Windows Search”. Stop the service.
c. Delete the Windows.edb file
d. Click “Modify” in the already-open “Indexing Options” panel, then click “Delete and Rebuild” for the index. You can also specify a different drive to store the index on.

Please note, there was an update in regards to this from Microsoft (KB 2838018) however it’s only relating on Windows 8 only NOT Windows 8.1.

Someone posted the paid solution from Microsoft based on this thread on the forum. The technician’s report of what he did is pasted below.

  • Edited the windows  search components
  • Followed this online instruction (http://www.eightforums.com/bsod-crashes-debugging/33651-crawl-could-not-completed-content-source-winrt. html)
  • Stopped and start the search services – run sfc /scannow
  • Run dism /online /cleanup-image /restorehealth
  • Run search and indexing troubleshooter
  • Run  hardware and device troubleshooter
  • Run windows update reset components
  • Run powershell with the command below
powershell Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "*SystemApps*"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
  • Restarted the pc and test the functionality of the resolution

References